Secunia released some interesting statistics last week; according to their numbers, at least 92% of the people using their PSI scanner that have Flase Player installed are running a version that is affected by the zero-day attack that was recently discovered. The real number might be even higher; they didn’t release combined numbers for users that had Flash 9 or Flash 10 installed.

psi

Meanwhile, Adobe is warning users to “[..] exercise caution in browsing untrusted websites.” While being cautious when browsing the web is good advice in general, I’d suggest disabling or deinstalling Flash Player entirely until Adobe releases a patch. The scheduled release date for a fixed Flash Player 10 is next thursday.