With the end of support for Firefox 2.0 coming in about a month, some users will be left out in the cold; version 3.0 of the popular browser is only supported on the latest Windows platforms. Here is a short summary of the platforms that will no longer be supported:

  • Windows 98
  • Windows 98 SE
  • Windows ME
  • Windows NT 4.0
  • MacOS X 10.2
  • MacOS X 10.3

While these are older operating systems that are no longer supported by their vendors, it’s still a significant amount of users. Wikipedia lists Windows 98 and NT as having about 1% combined market share; these users will now be forced to switch to Opera if they require an up-to-date browser that still receives security updates. 

Users of still-supported operating systems should of course upgrade to version 3.0 before support stops; while visitors of this site are much more likely to have an up-to-date system than the average user, there were still surprisingly many visitors using Firefox 2.0 (according to Clicky):

firefox-versions