I somehow missed this news last week: Google is starting to actively alert people using the Webmaster Tools when one of their sites is running outdated software that might have know vulnerabilities. Right now the checks are limited to WordPress 2.1.1, which has some serious security issues, but if this is a success the service will be expanded to include checks for other software. You get a polite message alerting you of the issue:

WordPress users will probably already know about this; modern versions notify you about updates as soon as you log in, and the typical webmaster will be checking his blog more often than the Google Webmaster Tools. But still, the idea is pretty good; you can’t get too many warnings if you’re running old software with known vulnerabilities. 

By the way, if you are blogging and are take security seriously, check out Blogsecurify for a comprehensive test suite that checks for multiple vulnerabilities.